Getting To Know Office 2007

Baffled by Office 2007’s new interface? Join the club. Making the switch to Word 2007 can be exceedingly disorienting -- like coming home and finding out that not only has all your furniture been rearranged, but the house itself has been moved to the next county.

Don’t worry. This document will guide you through all the major changes in the interface, offer tips and tricks for getting the most out of Office 2007, and clue you in on how to use the best of the new features.

Get the Lay of the Land

The new Excel 2007 Interface

The new Word 2007 Interface

The new PowerPoint 2007 Interface
The Microsoft Office Button. The big button on the upper left-hand corner of the screen replaces the old File menu from previous versions of Office. You'll find familiar features for opening files, saving files, printing files and so on, but there's a lot more here as well.

The Quick Access Toolbar. Just to the right of the Office Button is the Quick Access toolbar, with buttons for using Office's most common features, including Save, Undo, Redo, Print Preview and more -- but you can add and remove buttons for any functions you please.

The Ribbon. The Ribbon is the main way you'll work with Office. Instead of old-style menus, in which menus have submenus, submenus have sub-submenus and so on, the Ribbon groups buttons for common tasks together in tabs on a graphical interface. So, for example, when you click the Insert tab, a Ribbon appears with buttons for items that you can insert into a document, such as clip art, a hyperlink, a picture or a table.
**The Scrollbar.** This is largely unchanged from previous versions of Office; use it to scroll up and down. There are a couple of minor changes -- In Word, at the top, there's a small button that looks like a minus sign that lets you split your screen in two, and just below that, there's a small icon that displays or hides a ruler when you click it. In Excel, at the top, there's a double arrow that when clicked upon, expands the area at the top of the worksheet that displays the contents of the current cell. Just below the double arrow is a tiny button that looks like a minus sign that lets you split your screen in two.

**The View Toolbar.** The View toolbar lets you choose between various page views depending on what Office application you are in. There's also a nice addition -- a slider that lets you zoom in or out on your document.

**The Status Bar (Word 2007).** This is in the same place as in earlier Word versions and has the same function -- to display information such as the number of pages in your document. It has one nice little extra: It displays the word count of your document as well. If you highlight an area of text, it will display the number of words in the highlighted area.

**Learn to Love the Ribbon**

At first, the Ribbon may be off-putting, but the truth is, once you learn to use it, you'll find that it's far easier to use than the old Office interface. It does take some getting used to, though.

Each tab along the Ribbon is organized to make it easy to get your work done. As you can see above, each **tab** is organized into a series of **groups** that contain related commands for getting something done -- in our example, handling fonts. Inside each group is a set of what Microsoft calls **command buttons**, which carry out commands, display menus and so on -- in the example, the featured command button changes the font size. There's also a small diagonal arrow in the bottom right corner of some groups that Microsoft calls a **dialog box launcher**. Click it to display more options related to the group.
The Ribbon is divided into multiple tabs. Here's a rundown of the tabs and what each one does:

**Home:** This contains the most-used Office application features, such as changing fonts and font attributes, customizing paragraphs, inserting formulas, formatting tables, rows, cells and text, using styles, creating new slides, changing layouts, deleting slides and finding and replacing text.

**Insert:** As you might guess, this one handles anything you might want to insert into a document, such as tables, pictures, charts, hyperlinks, bookmarks, headers and footers, WordArt, etc.

**Page Layout:** Here's where you'll change margins, page size and orientation, set up columns, align objects, add effects and so on. There are some gray areas between this tab and the Home tab. For example, on the Page Layout tab you set paragraph spacing and indents, while on the Home tab you set paragraph alignment and can also set spacing between lines.

**Formulas (Excel only):** As the name says, it's where you'll go to insert and work with formulas. It organizes all of Excel's formulas into categories, such as Financial, Logical, Math & Trig, and so on, so they're all within easy reach. And it also gives you quick access to useful formula-checking features, such as error-checking and the ability to trace precedents and dependents.

**Data (Excel only):** Whatever you need to do with data, you'll find it here. For example, you can use this tab to import data from a wide variety of sources, including the Web, Access, SQL Server and so on. You'll also be able to filter and sort data, validate your data, group and ungroup data, and perform data analysis, among other features.

**Design (PowerPoint only):** Here's where you'll apply different themes to your presentation; change colors, fonts and effects; select background styles; change the slide orientation and page setup; and so on.

**Animations (PowerPoint only):** A more accurate name for this might be transitions, because it lets you control the animations used as transitions between slides. Creating transitions is now exceptionally easy: All you need to do is hover your mouse over an icon representation of a particular transition on this tab, and you'll see a live preview of that transition. You can also create custom animations, change transition sounds and speeds, and make other changes to animations as well.

**Slide Show (PowerPoint only):** Here's where you'll accomplish whatever you need to do with your slide show -- set it up, create a custom slide show, preview it from the beginning or current slide, rehearse your narration and timings, change the resolution, and so on.

**References (Word only):** This tab handles tables of contents, footnotes, bibliographies, indexes and similar material. It also lets you insert a "Table of Authorities," which is a list of references in a legal document.

**Mailings (Word only):** As the name says, this is where you'll go for anything to do with mailings, from something as simple as creating labels to the more daunting task of mail merges.

**Review:** Need to check spelling and grammar, look up a word in a thesaurus, work in markup mode, review other people's markups or compare documents? This is the tab for you.

**View:** Here's where to go when you want to change the view in any way, including displaying a ruler and gridlines, zooming in and out, splitting a window and so on.

**Developer:** If you write code or create forms and applications for Word, this is your tab. It also includes macro handling, so power users might also want to visit here every once in a while.
The Ribbon is also context-sensitive, changing according to what you’re doing. Depending on the task you’re engaged in, it sometimes adds more tabs and subtabs.

The Picture Tools - Format tab appears only when you need it. For example, when you insert and highlight a picture, an entirely new tab appears -- the Format tab, with a "Picture Tools" supertitle on top, as you can see to the left.

**The Office Button and Quick Access Toolbar**

There are two more new Office tools that you’ll want to get to know -- the Office Button and the Quick Access toolbar. Think of the Office Button as a greatly expanded File menu from previous Office suites. As you can see in the nearby figure, it's where to go for the various Open, Save, New, Print and related options and also includes a list of all your recently opened files.

There are two particularly noteworthy new features here as well -- Prepare and Convert. Use Prepare when you’ve finished writing or editing your document and you’re ready to send it to someone else. There are plenty of great new options here, such as marking a document as final or marking it read-only; encrypting the document;
inspecting it for hidden metadata and information you'd prefer remain private; and editing the document’s properties, such as title, keywords and author.

Convert lets you convert documents saved in older formats to the new Microsoft Office Open XML format (.docx, .xlsx, etc.), which is the new Office standard.

The Quick Access toolbar, sitting just to the right of the Office Button, is a nifty little tool that seems innocuous enough, but spend some time with it and you'll see it's one of the best additions to the new interface.

The three buttons on the left aren't particularly noteworthy -- Save, Undo and Redo -- but the nearly invisible Down arrow to the right of them is the key to the toolbar. Click it, and you'll be able to add and remove toolbar buttons for a preset list of commands. Customize the Quick Access toolbar to your liking, and you will hardly ever have to use the Ribbon.

**Tips for Working with Office 2007**

**Add Commands to the Quick Access Toolbar.** Probably the most helpful customization for Word 2007 is to add buttons the Quick Access toolbar. The simplest way to do this is by clicking the small Down arrow to the right of the Quick Access toolbar and selecting a new button to add. A better method is to click the Office Button, choose Options and then Customize.

**Use Keyboard Shortcuts.** If you're a fan of Office keyboard shortcuts, take heart -- the same ones work in 2007. So keep using them. You can also use a clever set of keyboard shortcuts for working with the Ribbon. Press the Alt key and a tiny letter or number icon appears on the menu for each tab -- for example, the letter H for the Home tab. (See the image below.) Now press that letter on your keyboard, and you'll display that tab or menu item. When the tab appears, there will be letters and numbers for most options on the tab as well.

**Getting Additional Help.** Use the F1 key on your keyboard to call up the Help feature in Office 2007.
New Features in Office

Word 2007

The Ribbon and the Quick Access toolbar are key innovations, as you've already seen, but also useful are the new mini toolbar, Live Preview and other features.

The Mini Toolbar. Having to move back and forth between the Ribbon and the body of your document is a big time-waster, and annoying to boot. So Word 2007 includes the clever mini toolbar. Highlight text and point the cursor at it, and a nearly transparent mini toolbar appears above the text, with a set of commands relevant to the text you've chosen. Move your cursor to the mini toolbar and it becomes solid; click a command to use it.

For example, as you can see below, if you select text, a mini toolbar will appear with various text-related commands, including font face, size and color, indentation, and list options. If the mini toolbar disappears for some reason, right-click the selection or reselect the text, and it springs back into action.

New File Format and Converting Files. The biggest change to Office is the new Office XML format -- all Microsoft Office applications now use it. By default, Office applications save in this new format, which, for instance, in the case of Word, has the .docx extension, or the .docm extension if the document contains macros.

In some instances, it also creates files of a smaller size, because files are automatically compressed when they're saved to disk and then automatically uncompressed when you open them.

In addition, the new format makes it easier to recover damaged files because it saves different data components -- such as tables and charts -- separately from one another. This means files can be opened even if an individual component, such as a chart, is damaged.

The only time this new format will be an issue is when sharing documents others not using Office 2007 or the Office 2007 Compatibility Pack. To save a document in the old .doc format, click the Office button and choose Save As > Word 97-2003 Document. When you open an older document or one created before converting, make changes, and go to save the document, it will save in the old format unless you choose Save As and select another format.
To convert a document from the old format to the new format, click the Office button, click Convert, then Save. The document will be saved in the new 2007 format unless Save As is selected and another format is chosen. The below dialog is displayed when converting files:

Themes. Have you ever tried making sure that your Word, Excel and PowerPoint documents all include a common look and feel?

Themes, new to Word 2007 and Office 2007, are designed to make doing that easier. You can create a single, overarching theme, with colors, logos, paragraph styles and so on, and then use that theme for all of your Office documents.

Themes may sound suspiciously like templates, but they're somewhat different. You can have multiple templates that use the same theme. So, for example, you could create a theme that includes your company logo, colors and font choice. You could then have one template in that style for letters, another for budget proposals and many others for different purposes.

To use Themes, select the Page Layout tab and click the Themes button to choose a new theme. You can also customize any theme and create new ones.

One important caveat: Be aware that themes only work if you're using Word's new Office XML format; they won't work on old-style .doc files.
Live Preview. If you often change formatting in your documents and text, you'll welcome the new Live Preview feature. Highlight the text or area of a document you want to change. Then, on the Ribbon, move your cursor over the format you want to apply. The text you highlighted will change so that you can see how it will look with the new formatting. Move the cursor away to revert to the original formatting, or move it over a different format to preview different formatting. When you find formatting you want to apply, click it.

![Live Preview feature image](image)

For example, if you are considering changing the font size of 10-point text, highlight the text. On the Home tab of the Ribbon, click the font size drop-down menu and hover your mouse over the text size you're considering changing the text to. You'll see the text in the new size. You can choose that text size by clicking it, preview other sizes or leave the text as is.

**Excel 2007**

In Excel 2007, more is truly better. Microsoft has increased the number of columns per spreadsheet (and per PivotTable) to 16,384 (up from 256) and the number of rows to 1,048,576 (up from 65,536). Other limits have been also expanded: Text cells can now contain more than 32,000 characters (up from 255).

Chances are you'll never reach other new limits: PivotTables can manipulate more than 16,000 fields (up from an already generous 255), and formulas can now refer to up to 8,000 cells (memory permitting), so it's fortunate that Excel 2007 lets you drag the corner of the formula bar to expand it.

Excel 2007’s memory manager can handle 2GB (double the amount in Excel 2003), so calculations execute faster. The new version also takes advantage of dual-core processors and multithreaded chip sets, so if you're lucky enough to be running it on a machine with either feature, expect a noticeable speed boost.

**New visualization tools.** Charts and graphs now support 16 million colors, and improved color support is evident throughout this version, especially in several new visual tools for highlighting data. For example, in Excel 2007 you can use conditional formatting to set the background color of a cell or use a colored bar (called a data bar) -- the length corresponds to the cell’s value.
You can also add icons to cells based on their value, giving your worksheet a dashboard-like quality. For example, assigning traffic-light icons to a range of cells is a snap, and Excel's built-in logic assigns colored circles based on the value of the cell: green for the highest third, yellow for the middle third and red for the bottom third.

Similarly, a four- or five-icon set (such as set of vertical bars similar to what your cell phone uses to indicate signal strength) displays icons based on which quartile or quintile the value falls into.

In all cases, you can control the ranges for each icon in the set -- allowing you, for instance, to use a green traffic light to indicate only the highest 10% of values.

**Better sorting and filtering.** Sorting data -- previously limited to three levels -- has been expanded to 64 levels. Best of all, while you can still sort data based on values (to sort a date column chronologically, for instance), you can also sort by font, color or icon used with conditional formatting. Thus, you can display all your green traffic lit cells together, followed by the yellow lights, then the red.
Other visualization tools eliminate the need for complicated macros or formulas. New conditional formatting options let you highlight duplicates, unique values, the top/bottom 10%, values above or below the average, cells less than or greater than a specified value, or cells within a range (highlighting cells containing values between 1 and 10, for example).

If you don't need to see all values, the vastly improved Filter feature puts check boxes (for up to 1,000 values) in a pull-down list, allowing you to easily pick multiple values to display. Likewise, the new Remove Duplicates feature hides rows based on the duplicate values in columns you specify.

**Working with PivotTables.** Among the notable improvements in Excel are tools to make existing features easier to use. Take PivotTables, for example. (For the uninitiated, PivotTables allow you to view your data differently -- think "slice and dice." For example, you can summarize sales by agent by month or, with a simple drag-and-drop motion, summarize sales by month and within month by agent.)

In Excel 2007, you still set up PivotTables using a wizard, which is slightly changed from Excel 2003. However, once you have a PivotTable defined, manipulating it is considerably easier.

Instead of dragging and dropping elements within the table itself, you can use the wizard to make choices -- checking boxes to select which fields to display or choose sorting options, for example. Excel 2007 makes it easier to switch columns and rows, filter values, and use or hide field names. In addition, conditional formatting (those data bars or traffic lights we mentioned) can be applied to cells displayed in PivotTables.

**Styles and Themes.** One of the promises of the Ribbon interface, according to Microsoft, is that some features are more obvious and usable. That's certainly true of Styles, a formatting tool from previous versions of Excel that is now available using a "gallery" interface introduced in Office 2007.
You can quickly apply a collection of settings, from the font used to the background color and border style to cells, tables and PivotTables. As you mouse over the choices, Excel 2007 applies each style to your selection so you can preview the effect without making the change permanent.
One particularly noteworthy improvement to formatting is how Styles now respond to changes within your worksheet. In Excel 2003, you could apply a "green bar" effect so that the background color in rows alternated between green and white. However, once you added a row, the pattern was interrupted, and you needed to reapply the AutoFormat, a clumsy and awkward procedure.

In Excel 2007, that same pattern is adjusted whenever you add one or more rows. (Styles are equally smart when you add columns, for patterns that alternate between columns.) Styles will even adjust when you filter or hide rows or columns.

Themes, new to Office 2007, are style collections that include a color scheme, font, fill effects and more. Shared by several Office 2007 applications, themes can be applied to charts, tables and PivotTables in Excel, giving your work a consistent look and feel. That's especially useful when you're creating a chart that you want to copy to PowerPoint or Word.

The Ribbon interface also makes it more enjoyable to work with charts. Excel's charts have a whole new look, thanks to the new graphics engine in all Office 2007 applications. The layouts use different color palettes and fonts, but the important difference is the ability to more easily apply graphical effects, such as bevels and shadows, to individual elements (such as columns or pie slices).

![Sales Chart](chart.png)

The Ribbon interface has a Chart Tools group (with tabs for Design, Layout and Format) to put more charting options at your fingertips and eliminate most of the right-clicking you had to do to adjust charts in previous versions: switching rows and columns, controlling gridlines and axes, and adding trend lines.

**Table tools.** Excel's new table features make it less likely you’ll have inconsistent formulas. Once you identify a contiguous range of cells as a table, Excel provides calculated columns. For example, if you add a column to the right of your table and enter a formula in any row, the formula will be copied to all cells in that new column, saving the time of executing a copy/paste command.

Even smarter, add a row and Excel is sure to include it in a total on the bottom row. (In previous versions of Excel, adding a row at the top or bottom of a range meant you risked omitting cells in that row from the sum formula.)

Furthermore, options on the Table Tools Design context-sensitive tab let you toggle the formatting of the first column or the first row. One click and you can add a Total row (though Excel lacks a similar command to add a Total column), then change what each column in that row computes (total, average, minimum and so on).
In addition, as you scroll down through a lengthy table, Excel replaces the column headings (the gray boxes with A/B/C above the columns) with values from the table's header row -- a subtle improvement, to be sure, but it's a more efficient technique than having to freeze rows to see column headings.

Finally, the new Table Gallery makes it easy to select and apply a sophisticated look.

One thing to note when working with older Excel spreadsheets, if you open an older file, make changes, and save you will get the below message box. This is just stating that you may have made modifications using elements of Office 2007 that will not translate back to the older versions. If this is a concern, you can simply click the Office button and click Save As to save in the newer format.
Preston Gralla, *Word 2007 Cheat Sheet*
Computer World, April 3, 2007
<http://www.computerworld.com/action/article.do?command=viewArticleBasic&articleId=9010482>

Preston Gralla and Richard Ericson, *Excel 2007 Cheat Sheet*
Computer Word, August 2, 2007
r=1>

Preston Gralla, *PowerPoint 2007 Cheat Sheet*
Computer World, March 6, 2008
<http://www.computerworld.com/action/article.do?command=viewArticleBasic&taxonomyName=Software&artic
leId=9063119&taxonomyId=18&pageNumber=1>